Erro
  • XML Parsing Error at 1:377. Error 4: not well-formed (invalid token)
PDF Imprimir E-mail
Internacional
Sex, 15 de Abril de 2011 18:47

As pessoas estão (se) perguntando como as atualizações de Joomla 1.5 para 1.6 estão acontecendo para sites de clientes. Elas também estão debatendo se criam sites em Joomla 1.5 ou 1.6 neste momento (Fevereiro de 2011).

Estas são importantes perguntas a se considerar, mas para nós 4Web, as respostas são muito claras.

Primeiramente, a lidenrança Joomla fez um anúncio quanto ao caminho a ser seguido para Joomla 1.7 e 1.8, assim como o suporte ao Joomla 1.5. Todas as empresas que dependem do Joomla para seus websites precisam ler este artigo muito importante. Isso impacta profundamente seus negócios.

Resumidamente, eis alguns fatos do referido artigo:

Baseado no "caminho" a ser seguido, Joomla 1.6 estará em desenvolvimento ativo até Julho de 2011.
  • Joomla 1.7 está para ser lançado em Julho de 2011. Este, por sua vez permanecerá em desenvolvimento ativo até Janeiro de 2012.
  • "Joomla 1.8" (nome ainda não oficial), o próximo lançamento estável de período longo, é para ser lançado em Janeiro de 2012. Este terá suporte por um período mais longo que o 1.6 ou 1.7 - pelo menos por 15 meses.
  • Joomla 1.5 terá suporte até Abril de 2012, quando alcançará seu fim.
  • Uma ferramenta para migração será disponibilizada para mover sites em Joomla 1.5, 1.6, e 1.7 para "Joomla 1.8".

Se você estiver adotando o Joomla 1.6 hoje, você estará utilizando software que receberá suporte por um período de tempo MAIS CURTO que Joomla 1.5. Você, definitivamente, precisará fazer um upgrade para clientes com sites em 1.6 para 1.7 ou 1.8 eventualmente. E, devido a longos períodos de desenvolvimento para criação de alguns sites, 1.7 deverá ser lançado antes que você finalize seu site em 1.6.

Junte a isso o tempo que leva para desenvolvedores Joomla atualizarem suas extensões e templates para Joomla 1.6, e depois potencialmente para Joomla 1.7, e eu acredito que o caminho esteja bem claro.

4Web não está criando novos sites em Joomla 1.6 ou 1.7, a menos que haja uma razão muito convincente para tal. Para nós, isso seria por precisarmos das funcionalidades de ACL, ou por precisarmos das funcionalidade de acessibilidade que estão disponíveis no core. Caso contrário, estamos criando sites em 1.5 até que o "1.8" esteja disponível.

Além disso, não recomendamos atualização (upgrade) de quaisquer sites existentes em Joomla 1.5 para 1.6 ou 1.7, a menos que haja uma razão muito convincente para tal. A partir do momento em que "Joomla 1.8" for lançado, e extensões e templates estejam sendo lançados, estaremos conversando com nossos clientes a respeito da migração de seus sites.

O texto acima é uma tradução, na íntegra, de um artigo escrito e publicado por Jen Kramer em 03 de Fevereiro de 2011 conforme link a seguir:

Joomla 1.6 and Beyond: Should I upgrade? Should I build my new sites in it?

 

Disclaimer

iikozen.com.br is not affiliated with nor endorsed by the Joomla! Project or Open Source Matters. The Joomla! logo and name are used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.